summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2020-12-28 18:24:10 -0800
committerKevin McCarthy <kevin@8t8.us>2020-12-28 18:24:10 -0800
commita62d11d21965e64eece0b1bc4c6b5179606398d9 (patch)
treeb8da836b13f8cc4abd31d51d55e274da1edd1464 /configure.ac
parent60bd4a85e7fd9b94e9c30e0c20975ba36f4eba19 (diff)
Add non-zero length for gdbm and lmdb configure tests.
In $db_requested=auto mode, the variables may be unset.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8d17d819..47b0cc86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1137,7 +1137,7 @@ then
if test x$with_gdbm != xno && test $db_found = no \
&& test "$db_requested" = auto -o "$db_requested" = gdbm
then
- if test "$with_gdbm" != "yes"
+ if test -n "$with_gdbm" && test "$with_gdbm" != "yes"
then
CPPFLAGS="$CPPFLAGS -I$with_gdbm/include"
LDFLAGS="$LDFLAGS -L$with_gdbm/lib"
@@ -1200,7 +1200,7 @@ then
if test x$with_lmdb != xno && test $db_found = no \
&& test "$db_requested" = auto -o "$db_requested" = lmdb
then
- if test "$with_lmdb" != "yes"
+ if test -n "$with_lmdb" && test "$with_lmdb" != "yes"
then
CPPFLAGS="$CPPFLAGS -I$with_lmdb/include"
LDFLAGS="$LDFLAGS -L$with_lmdb/lib"