summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2019-04-21 11:00:23 -0700
committerKevin McCarthy <kevin@8t8.us>2019-04-21 14:34:06 -0700
commit9da6bde1feafbe886c295027b959be47b4ad55b0 (patch)
treeb9f6977bef4dc8c40a85bca9b480bf8a1b5a2299 /configure.ac
parent4dcb3ba1a9c7bf1de44fa9d2efa8dd76638a1a1b (diff)
Fix unistring library configure test.
The "action-if-found" argument of AC_SEARCH_LIBS is run even if the result is "none required" (i.e. the test function is already in LIBS, in this case -lidn2). This was causing "-lunistring" to be appended on a system without the library installed, generating a build error. Fix the test to not append the library for the "none required" case. Thanks to Fabrice Fontaine for reporting this issue and helping me test the fix.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 75943eee..102ddea2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1401,10 +1401,16 @@ if test "x$with_idn2" != "xno"; then
AC_SEARCH_LIBS([idn2_check_version], [idn2], [
AC_DEFINE([HAVE_LIBIDN2], 1, [Define to 1 if you have the GNU idn2 library])
- dnl -lunistring is needed for static linking
- AC_SEARCH_LIBS([u8_strconv_from_locale], [unistring], [LIBS="$LIBS -lunistring"])
MUTTLIBS="$MUTTLIBS $LIBS"
+ dnl -lunistring is needed for static linking, and has to come
+ dnl after the -lidn2
+ AC_SEARCH_LIBS([u8_strconv_from_locale], [unistring], [
+ if test "$ac_cv_search_u8_strconv_from_locale" != "none required"; then
+ MUTTLIBS="$MUTTLIBS -lunistring"
+ fi
+ ])
+
dnl libidn2 >= 2.0.0 declares compatibility macros in idn2.h
LIBS="$LIBS $LIBICONV"
AC_CHECK_DECL([idna_to_unicode_8z8z],