summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2019-05-19 10:14:09 -0700
committerKevin McCarthy <kevin@8t8.us>2019-05-19 15:12:29 -0700
commit7bef99de54fe39ab4d823845a80d3cc958f4974e (patch)
tree539c4a018687e6594bc1fe750fba63afe65ee1a6 /configure.ac
parentcc8a201f6b10c67ef89e881f51a19caadcf2be53 (diff)
Update gpgme and gpg-error automake checks.
Pull updated autoconf files from the GPGME 1.13.0 release and use those new macros. Add a call to AM_PATH_GPG_ERROR() and include $(GPG_ERROR_LIBS) in the libraries. Thanks to Eike Rathke for finding the build problem, and for his patch fixing the issue. I opted for just grabbing the newest autoconf files from gpgme instead, but his fixed worked great too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 102ddea2..9b355e7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,6 +133,7 @@ if test x"$enable_gpgme" = xyes; then
AC_MSG_ERROR([*** GPGME not found or version is older than 1.4 ***])
else
MUTT_LIB_OBJECTS="$MUTT_LIB_OBJECTS crypt-gpgme.o crypt-mod-pgp-gpgme.o crypt-mod-smime-gpgme.o"
+ AM_PATH_GPG_ERROR(1.33)
fi
else
AC_MSG_RESULT([no])