summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2019-08-20 14:57:29 -0700
committerKevin McCarthy <kevin@8t8.us>2019-08-20 14:57:29 -0700
commit577d5d1407672941763ce45167975cbb45d96bf5 (patch)
tree75c7b8789a2ed65e2f8001fee4e53270add3122d /configure.ac
parentd4ec818aab1b6052eef351209adadd6e4a504943 (diff)
Fix --with-sqlite3 test for autocrypt.
Since $with_sqlite3 can contain a path, we want to check if it is "no", not that it isn't "yes".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 08f5e380..7c03844e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,7 +149,7 @@ AC_ARG_ENABLE(autocrypt,
[],
[enable_autocrypt=no])
if test x$enable_autocrypt = xyes; then
- if test x$with_sqlite3 != xyes; then
+ if test x$with_sqlite3 = xno; then
AC_MSG_ERROR([autocrypt requires --with-sqlite3])
fi
AC_DEFINE(USE_AUTOCRYPT,1,[ Define if you want support for autocrypt. ])