summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2020-12-24 15:33:57 -0800
committerKevin McCarthy <kevin@8t8.us>2020-12-25 10:14:36 -0800
commit48d08860508d45118037c7d7dee802acd0b50221 (patch)
treec4d405a53f3bcbf6c48ce2ca00ed56c5d5769392 /configure.ac
parent11b18027d3d710f30c78e1171ea8ee94f75f0ac1 (diff)
Fix header cache BDB version checking.
Update BDB versions up to 6.2. The scheme used here is, as Oswald nicely puts it, "totally insane", and seems to come straight from the initial header cache commit in c11667eaa3. For a stable release, I'm just going to add a few more Jenga pieces to the top. However, going forward this is unmaintainable. Oswald reports using a simple check for "db.h" and "-ldb" for about two decades with no issues. I will make that change in master later this week.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 661e6ccd..81f88099 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1176,7 +1176,7 @@ then
bdbpfx="$bdbpfx $d/$v"
done
done
- BDB_VERSIONS="db-4 db4 db-5 db5 db-5.2 db5.2 db52 db-5.1 db5.1 db51 db-5.0 db5.0 db50 db-4.8 db4.8 db48 db-4.7 db4.7 db47 db-4.6 db4.6 db46 db-4.5 db4.5 db45 db-4.4 db4.4 db44 db-4.3 db4.3 db43 db-4.2 db4.2 db42 db-4.1 db4.1 db41 db ''"
+ BDB_VERSIONS="db-4 db4 db-6 db6 db-6.2 db6.2 db62 db-6.1 db6.1 db61 db-6.0 db6.0 db60 db-5 db5 db-5.3 db5.3 db53 db-5.2 db5.2 db52 db-5.1 db5.1 db51 db-5.0 db5.0 db50 db-4.8 db4.8 db48 db-4.7 db4.7 db47 db-4.6 db4.6 db46 db-4.5 db4.5 db45 db-4.4 db4.4 db44 db-4.3 db4.3 db43 db-4.2 db4.2 db42 db-4.1 db4.1 db41 db ''"
AC_MSG_CHECKING([for BerkeleyDB > 4.0])
for d in $bdbpfx; do
BDB_INCLUDE_DIR=""