summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2015-08-11 11:20:15 -0700
committerKevin McCarthy <kevin@8t8.us>2015-08-11 11:20:15 -0700
commitfe2144d6e10971a794b9a286f1f66e4180fb4c8e (patch)
tree4a4234f6de3f4264a87787a5e31eb03f378dec25 /Makefile.am
parent9d8121e9b8f909d90583922a81bd3ea23b3798ea (diff)
Compile txt2c using automake rules.
The compilation rule used $< which isn't portable for ordinary make rules.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 24c73186..baff5386 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -89,15 +89,14 @@ mutt_md5_SOURCES = md5.c
mutt_md5_CFLAGS = -DMD5UTIL
mutt_md5_LDADD =
-noinst_PROGRAMS = $(MUTT_MD5)
+txt2c_SOURCES = txt2c.c
+txt2c_LDADD =
+
+noinst_PROGRAMS = $(MUTT_MD5) txt2c
mutt_dotlock.c: dotlock.c
cp $(srcdir)/dotlock.c mutt_dotlock.c
-# If this fails, we will fall back to the implementation in txt2c.sh
-txt2c: txt2c.c
- -$${NATIVECC-$(CC)} -o $@ $<
-
conststrings.c: txt2c config.status
( \
$(CC) -v || \