summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2015-07-09 14:50:05 -0700
committerKevin McCarthy <kevin@8t8.us>2015-07-09 14:50:05 -0700
commit32de2adc620a155f6ba90075df2694209fb6f292 (patch)
tree474d41fe82961ebdf845be8fa4c0eeb92aa9ec97 /Makefile.am
parent61289d13457b6c80ec97ac0787abea9ca7094aec (diff)
Use $(VAR) instead of @VAR@ in Makefile.am files. (closes #3664)
The @VAR@ form is not overridable, such as the case for #3664 where the reporter wanted to override DOTLOCK_GROUP. It's doubtful targets need to be overriden, but it makes sense to be consistent in the usage of automake substituted variables unless there is a particular reason/bug to work around.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 12 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ac3a0a4..24c73186 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,7 @@ endif
SUBDIRS = m4 po intl doc contrib $(IMAP_SUBDIR)
-bin_SCRIPTS = muttbug flea @SMIMEAUX_TARGET@
+bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET)
if BUILD_HCACHE
HCVERSION = hcversion.h
@@ -20,7 +20,7 @@ endif
BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h conststrings.c $(HCVERSION)
-bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
+bin_PROGRAMS = mutt $(DOTLOCK_TARGET) $(PGPAUX_TARGET)
mutt_SOURCES = \
addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
crypt.c cryptglue.c \
@@ -38,10 +38,10 @@ mutt_SOURCES = \
nodist_mutt_SOURCES = $(BUILT_SOURCES)
-mutt_LDADD = @MUTT_LIB_OBJECTS@ @LIBOBJS@ $(LIBIMAP) $(MUTTLIBS) \
+mutt_LDADD = $(MUTT_LIB_OBJECTS) $(LIBOBJS) $(LIBIMAP) $(MUTTLIBS) \
$(INTLLIBS) $(LIBICONV) $(GPGME_LIBS)
-mutt_DEPENDENCIES = @MUTT_LIB_OBJECTS@ @LIBOBJS@ $(LIBIMAPDEPS) \
+mutt_DEPENDENCIES = $(MUTT_LIB_OBJECTS) $(LIBOBJS) $(LIBIMAPDEPS) \
$(INTLDEPS)
DEFS=-DPKGDATADIR=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(sysconfdir)\" \
@@ -50,8 +50,6 @@ DEFS=-DPKGDATADIR=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(sysconfdir)\" \
AM_CPPFLAGS=-I. -I$(top_srcdir) $(IMAP_INCLUDES) $(GPGME_CFLAGS) -Iintl
-CPPFLAGS=@CPPFLAGS@
-
EXTRA_mutt_SOURCES = account.c bcache.c crypt-gpgme.c crypt-mod-pgp-classic.c \
crypt-mod-pgp-gpgme.c crypt-mod-smime-classic.c \
crypt-mod-smime-gpgme.c dotlock.c gnupgparse.c hcache.c md5.c \
@@ -80,12 +78,12 @@ EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
EXTRA_SCRIPTS = smime_keys
mutt_dotlock_SOURCES = mutt_dotlock.c
-mutt_dotlock_LDADD = @LIBOBJS@
-mutt_dotlock_DEPENDENCIES = @LIBOBJS@
+mutt_dotlock_LDADD = $(LIBOBJS)
+mutt_dotlock_DEPENDENCIES = $(LIBOBJS)
pgpring_SOURCES = pgppubring.c pgplib.c lib.c extlib.c sha1.c md5.c pgppacket.c ascii.c
-pgpring_LDADD = @LIBOBJS@ $(INTLLIBS)
-pgpring_DEPENDENCIES = @LIBOBJS@ $(INTLDEPS)
+pgpring_LDADD = $(LIBOBJS) $(INTLLIBS)
+pgpring_DEPENDENCIES = $(LIBOBJS) $(INTLDEPS)
mutt_md5_SOURCES = md5.c
mutt_md5_CFLAGS = -DMD5UTIL
@@ -119,7 +117,7 @@ DISTCLEANFILES= flea smime_keys txt2c po/mutt.pot
ACLOCAL_AMFLAGS = -I m4
-LDADD = @LIBOBJS@ @INTLLIBS@
+LDADD = $(LIBOBJS) $(INTLLIBS)
flea: muttbug.sh
cp muttbug.sh flea
@@ -155,9 +153,9 @@ install-exec-hook:
rm -f $(DESTDIR)$(bindir)/mutt.dotlock ; \
ln -sf $(DESTDIR)$(bindir)/mutt_dotlock $(DESTDIR)$(bindir)/mutt.dotlock ; \
fi
- if test -f $(DESTDIR)$(bindir)/mutt_dotlock && test x@DOTLOCK_GROUP@ != x ; then \
- chgrp @DOTLOCK_GROUP@ $(DESTDIR)$(bindir)/mutt_dotlock && \
- chmod @DOTLOCK_PERMISSION@ $(DESTDIR)$(bindir)/mutt_dotlock || \
+ if test -f $(DESTDIR)$(bindir)/mutt_dotlock && test x$(DOTLOCK_GROUP) != x ; then \
+ chgrp $(DOTLOCK_GROUP) $(DESTDIR)$(bindir)/mutt_dotlock && \
+ chmod $(DOTLOCK_PERMISSION) $(DESTDIR)$(bindir)/mutt_dotlock || \
{ echo "Can't fix mutt_dotlock's permissions! This is required to lock mailboxes in the mail spool directory." >&2 ; exit 1 ; } \
fi