summaryrefslogtreecommitdiffstats
path: root/build/debian
diff options
context:
space:
mode:
authorRJ Skerry-Ryan <rryan@mixxx.org>2018-09-13 08:58:51 -0700
committerRJ Skerry-Ryan <rryan@mixxx.org>2018-09-13 08:58:51 -0700
commiteef25b7ca29304a6e8f744d439784dfa8fd80fe0 (patch)
treed4cbc1181824c30fa3a0b78474cfff3055e3c7cd /build/debian
parent088f6981bfa5a5eba254ad9de0e808caff84dd2b (diff)
Indent if statements in build/debian/rules.
Diffstat (limited to 'build/debian')
-rwxr-xr-xbuild/debian/rules10
1 files changed, 6 insertions, 4 deletions
diff --git a/build/debian/rules b/build/debian/rules
index 400e912efd..33daf1fd3a 100755
--- a/build/debian/rules
+++ b/build/debian/rules
@@ -1,6 +1,8 @@
#!/usr/bin/make -f
# -*- makefile -*-
+# Documentation: https://www.debian.org/doc/debian-policy/ch-source.html#main-building-script-debian-rules
+
# no thanks dpkg-buildpackage, we will handle our own C++ optimizations
DEB_BUILD_OPTIONS= noopt
@@ -11,16 +13,16 @@ MIXXX_SCONS_FLAGS = ""
# will be set to create an environment to build packages for the architecture
# specified in ARCH.
ifneq (,$(findstring i386,$(ARCH)))
- MIXXX_SCONS_FLAGS += machine=x86
+ MIXXX_SCONS_FLAGS += machine=x86
endif
ifneq (,$(findstring amd64,$(ARCH)))
- MIXXX_SCONS_FLAGS += machine=x86_64
+ MIXXX_SCONS_FLAGS += machine=x86_64
endif
# parallel builds for scons
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-MIXXX_SCONS_FLAGS += -j$(NUMJOBS)
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ MIXXX_SCONS_FLAGS += -j$(NUMJOBS)
endif
MIXXX_SCONS_FLAGS += prefix=/usr