summaryrefslogtreecommitdiffstats
path: root/build/debian
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2020-05-13 18:13:07 +0200
committerUwe Klotz <uklotz@mixxx.org>2020-05-13 18:13:07 +0200
commitd7b5e1b71631b960cffa6506a2d5746c05aa7bdf (patch)
treea1e3150effb163001ddfc8b04c3ab392584e4fa8 /build/debian
parent57c93eb02c55e9d98a8314c49214ab124aa72d33 (diff)
parent6034875659498ff5b8aa0f24bec381672f2261b9 (diff)
Merge branch '2.2' of git@github.com:mixxxdj/mixxx.git into 2.3
# Conflicts: # CHANGELOG # build/debian/rules
Diffstat (limited to 'build/debian')
-rw-r--r--[-rwxr-xr-x]build/debian/rules11
1 files changed, 7 insertions, 4 deletions
diff --git a/build/debian/rules b/build/debian/rules
index 343d719415..7191d81a7b 100755..100644
--- a/build/debian/rules
+++ b/build/debian/rules
@@ -6,15 +6,18 @@
# Build flags are passed in from the SConscript. The following line is replaced
# via exact-string matching so do not change it!
MIXXX_SCONS_FLAGS = ""
+MIXXX_BUILD_FOLDER = "linux_build"
# If ARCH is set to a different architecture when running pbuilder, pbuilder
# will be set to create an environment to build packages for the architecture
# specified in ARCH.
ifneq (,$(findstring i386,$(ARCH)))
- MIXXX_SCONS_FLAGS += machine=x86
+ MIXXX_SCONS_FLAGS += machine=x86
+ MIXXX_BUILD_FOLDER = "lin32_build"
endif
ifneq (,$(findstring amd64,$(ARCH)))
- MIXXX_SCONS_FLAGS += machine=x86_64
+ MIXXX_SCONS_FLAGS += machine=x86_64
+ MIXXX_BUILD_FOLDER = "lin64_build"
endif
# parallel builds for scons
@@ -49,9 +52,9 @@ endif
override_dh_auto_clean:
scons $(MIXXX_SCONS_FLAGS) -c || true
- rm -rf .sconf_temp/ cache/ linux_build/
+ rm -rf .sconf_temp/ cache/ $(MIXXX_BUILD_FOLDER)/
dh_clean .sconsign.dblite cachecustom.py \
- config.log src/build.h build/*.pyc mixxx.1
+ config.log src/build.h build/*.pyc mixxx.1 lib/*/lib/*.a
dh_auto_clean
override_dh_auto_install: