summaryrefslogtreecommitdiffstats
path: root/build/debian
diff options
context:
space:
mode:
authorBe <be@mixxx.org>2019-11-16 11:22:18 -0600
committerBe <be@mixxx.org>2019-11-16 11:22:18 -0600
commitcebab53da98958dbb861b38b858cfb9903107fe5 (patch)
tree794b226f95be7fafc17f9586a8e82b566df90ea7 /build/debian
parentb52206936ec7c62efd4532de9a5f8caad69d6554 (diff)
attempt to fix Ubuntu package build
Since CMake support has been merged, dh_auto_configure is trying to use it automatically, but for 2.3 we are still using SCons.
Diffstat (limited to 'build/debian')
-rwxr-xr-xbuild/debian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/build/debian/rules b/build/debian/rules
index 81aad95fba..343d719415 100755
--- a/build/debian/rules
+++ b/build/debian/rules
@@ -33,6 +33,11 @@ MIXXX_SCONS_FLAGS += install_root=$(CURDIR)/debian/tmp/usr
%:
dh $@ --parallel
+# dh_auto_configure will attempt to run cmake instead of scons
+# nothing needs to be done for the configure step; scons is run in the build step below
+override_dh_auto_configure:
+ :
+
override_dh_auto_build:
scons $(MIXXX_SCONS_FLAGS)
docbook-to-man debian/mixxx.sgml > mixxx.1