summaryrefslogtreecommitdiffstats
path: root/build/debian
diff options
context:
space:
mode:
authorRJ Ryan <rryan@mixxx.org>2018-09-18 21:00:54 -0700
committerRJ Ryan <rryan@mixxx.org>2018-09-20 18:21:54 -0700
commit93e00aa839ff5cef71873ddf5f531dadd8a14fce (patch)
treebb53483c5d0dc443d023b7c698637345107b63ef /build/debian
parentd4bf7a3078a5f8915be59289eb5cb09585edfbe5 (diff)
Debian package updates.
- Add libmp3lame-dev and xvfb to Build-Depends. - Add pulseaudio-utils to Depends (for pasuspender). - Build and run the tests in the packaging process. - Fix syntax error in the changelog. - Fix my name. - Write built .deb directly to ubuntu/... instead of /var/cache/pbuilder. - Add a mixxx-test Debian package so users can also install mixxx-test.
Diffstat (limited to 'build/debian')
-rw-r--r--build/debian/changelog4
-rw-r--r--build/debian/control24
-rw-r--r--build/debian/copyright4
-rw-r--r--build/debian/mixxx-test.install2
-rw-r--r--build/debian/mixxx.install2
-rwxr-xr-xbuild/debian/rules18
6 files changed, 41 insertions, 13 deletions
diff --git a/build/debian/changelog b/build/debian/changelog
index 19145cc9d4..7be287a008 100644
--- a/build/debian/changelog
+++ b/build/debian/changelog
@@ -2,13 +2,13 @@ mixxx (2.1.4-0ubuntu1) bionic; urgency=medium
* New upstream release.
- -- Be <be@mixxx.org> Mon, 30 Aug 2018 07:47:00 +0500
+ -- Be <be@mixxx.org> Mon, 30 Aug 2018 07:47:00 +0500
mixxx (2.1.3-0ubuntu1) bionic; urgency=medium
* New upstream release.
- -- Be <be@mixxx.org> Mon, 20 Aug 2018 12:53:15 +0500
+ -- Be <be@mixxx.org> Mon, 20 Aug 2018 12:53:15 +0500
mixxx (2.1.2-0ubuntu1) artful; urgency=medium
diff --git a/build/debian/control b/build/debian/control
index 2f2e5af868..b5144d1990 100644
--- a/build/debian/control
+++ b/build/debian/control
@@ -1,7 +1,7 @@
Source: mixxx
Section: sound
Priority: optional
-Maintainer: RJ Ryan <rryan@mixxx.org>
+Maintainer: RJ Skerry-Ryan <rryan@mixxx.org>
Build-Depends: debhelper (>= 9),
pkg-config,
docbook-to-man,
@@ -46,7 +46,10 @@ Build-Depends: debhelper (>= 9),
libsoundtouch-dev,
libhidapi-dev,
libupower-glib-dev,
- liblilv-dev
+ liblilv-dev,
+ libmp3lame-dev,
+# for running mixxx-test
+ xvfb
Standards-Version: 3.9.8
Homepage: http://www.mixxx.org/
@@ -59,8 +62,9 @@ Depends: ${shlibs:Depends},
libqt5svg5,
libqt5xml5,
libqt5sql5,
- libqt5sql5-sqlite
-Recommends: libmp3lame0
+ libqt5sql5-sqlite,
+# for pasuspender
+ pulseaudio-utils
Suggests: pdf-viewer
Replaces: mixxx-data
Description: Free Digital DJ software. Start making live DJ mixes today.
@@ -105,3 +109,15 @@ Description: Free Digital DJ software. Start making live DJ mixes today.
- Multiple simultaneous MIDI/HID controllers
- Multi-core CPU support
- 24-bit/96000 Hz playback and capture
+
+Package: mixxx-test
+Section: sound
+Architecture: linux-any
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ libqt5opengl5,
+ libqt5svg5,
+ libqt5xml5,
+ libqt5sql5,
+ libqt5sql5-sqlite
+Description: The Mixxx test suite. \ No newline at end of file
diff --git a/build/debian/copyright b/build/debian/copyright
index b9380c7b27..1e5a248d56 100644
--- a/build/debian/copyright
+++ b/build/debian/copyright
@@ -1,8 +1,8 @@
Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: Mixxx
Upstream-Contact:
- RJ Ryan <rryan@mixxx.org>
-Source: http://downloads.mixxx.org/
+ RJ Skerry-Ryan <rryan@mixxx.org>
+Source: https://downloads.mixxx.org/
Files: *
Copyright:
diff --git a/build/debian/mixxx-test.install b/build/debian/mixxx-test.install
new file mode 100644
index 0000000000..38754b9969
--- /dev/null
+++ b/build/debian/mixxx-test.install
@@ -0,0 +1,2 @@
+usr/bin/mixxx-test
+usr/share/mixxx-test/test_results.xml \ No newline at end of file
diff --git a/build/debian/mixxx.install b/build/debian/mixxx.install
index e0ddb4cb60..429d081733 100644
--- a/build/debian/mixxx.install
+++ b/build/debian/mixxx.install
@@ -1,4 +1,4 @@
-usr/bin
+usr/bin/mixxx
usr/share/pixmaps
usr/share/applications
usr/share/mixxx
diff --git a/build/debian/rules b/build/debian/rules
index 33daf1fd3a..81aad95fba 100755
--- a/build/debian/rules
+++ b/build/debian/rules
@@ -3,10 +3,8 @@
# Documentation: https://www.debian.org/doc/debian-policy/ch-source.html#main-building-script-debian-rules
-# no thanks dpkg-buildpackage, we will handle our own C++ optimizations
-DEB_BUILD_OPTIONS= noopt
-
-# Build flags are passed in from the SConscript.
+# Build flags are passed in from the SConscript. The following line is replaced
+# via exact-string matching so do not change it!
MIXXX_SCONS_FLAGS = ""
# If ARCH is set to a different architecture when running pbuilder, pbuilder
@@ -25,6 +23,10 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
MIXXX_SCONS_FLAGS += -j$(NUMJOBS)
endif
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ MIXXX_SCONS_FLAGS += test=1
+endif
+
MIXXX_SCONS_FLAGS += prefix=/usr
MIXXX_SCONS_FLAGS += install_root=$(CURDIR)/debian/tmp/usr
@@ -35,6 +37,11 @@ override_dh_auto_build:
scons $(MIXXX_SCONS_FLAGS)
docbook-to-man debian/mixxx.sgml > mixxx.1
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ xvfb-run -- ./mixxx-test --gtest_output=xml:test_results.xml
+endif
+
override_dh_auto_clean:
scons $(MIXXX_SCONS_FLAGS) -c || true
rm -rf .sconf_temp/ cache/ linux_build/
@@ -44,6 +51,9 @@ override_dh_auto_clean:
override_dh_auto_install:
scons $(MIXXX_SCONS_FLAGS) install
+ mkdir $(CURDIR)/debian/tmp/usr/share/mixxx-test
+ cp test_results.xml $(CURDIR)/debian/tmp/usr/share/mixxx-test/
+ cp mixxx-test $(CURDIR)/debian/tmp/usr/bin
find $(CURDIR)/debian/tmp \( -name COPYING -o -name Thumbs.db \
-o -name shifter.sh -o -name '*.xsl' -o -name '*.php' \) \
-exec rm -f {} \;