summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-15 20:24:18 +0100
committerGitHub <noreply@github.com>2020-11-15 20:24:18 +0100
commitdda5489ccedf1be6e23ffd5c00e36d19987b5903 (patch)
tree2115316892c3e05913eea6a5cc8cd60c977044b9 /CMakeLists.txt
parentebe12558bf65c4309ceb5df4decc270a546f3bf4 (diff)
parent636bb91012f6273bae639496e04bd86f1c72da07 (diff)
Merge pull request #3255 from Be-ing/appveyor_clcache
get clcache to work on AppVeyor Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47bf7f3a42..8fc17dc634 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1035,6 +1035,8 @@ if(WIN32)
target_link_libraries(mixxx-lib PUBLIC shell32)
if(MSVC)
+ # needed for clcache
+ target_compile_options(mixxx-lib PUBLIC /c)
if(NOT STATIC_DEPS OR CMAKE_BUILD_TYPE STREQUAL "Debug")
target_link_options(mixxx-lib PUBLIC /nodefaultlib:LIBCMT.lib /nodefaultlib:LIBCMTd.lib)
endif()