summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2021-04-17 20:09:22 +0200
committerUwe Klotz <uklotz@mixxx.org>2021-04-17 20:09:22 +0200
commitdc7b1d4fbb59bac6bab3461f01f186d6ced7204c (patch)
treead9bb0dcc12930720ab53ded7d1d9d9ae149f513 /CMakeLists.txt
parent0936681e9d844991520bdf383223acef4adc2248 (diff)
parentfb118cce05000a49b33bef2c7b3f47a6d424d692 (diff)
Merge branch 'main' into remove-trackfile
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 717a1d83b5..72be447a74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,7 @@ if(POLICY CMP0071)
cmake_policy(SET CMP0071 NEW)
endif()
-project(mixxx VERSION 2.3.0)
+project(mixxx VERSION 2.4.0)
set(CMAKE_PROJECT_HOMEPAGE_URL "https://www.mixxx.org")
set(CMAKE_PROJECT_DESCRIPTION "Mixxx is Free DJ software that gives you everything you need to perform live mixes.")
@@ -1721,6 +1721,8 @@ if(ENGINEPRIME)
set(DJINTEROP_INSTALL_DIR "${CMAKE_CURRENT_BINARY_DIR}/lib/libdjinterop-install")
set(DJINTEROP_LIBRARY "lib/${CMAKE_STATIC_LIBRARY_PREFIX}djinterop${CMAKE_STATIC_LIBRARY_SUFFIX}")
file(MAKE_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/download")
+ # External project sources must be downloaded as an archive into DOWNLOAD_DIR
+ # from an URL to keep offline builds like for Fedora/RPM Fusion working!
ExternalProject_Add(libdjinterop
URL "https://github.com/xsco/libdjinterop/archive/0.15.1.tar.gz"
URL_HASH SHA256=87b3e6c726c208333d55b7e7e3af0a7230c9ad9edb3ca0ca81feffe17b3fc008
@@ -1828,6 +1830,8 @@ if(KEYFINDER)
set(KeyFinder_INSTALL_DIR "${CMAKE_CURRENT_BINARY_DIR}/lib/keyfinder-install")
set(KeyFinder_LIBRARY "${CMAKE_INSTALL_LIBDIR}/${CMAKE_STATIC_LIBRARY_PREFIX}keyfinder${CMAKE_STATIC_LIBRARY_SUFFIX}")
file(MAKE_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/download")
+ # External project sources must be downloaded as an archive into DOWNLOAD_DIR
+ # from an URL to keep offline builds like for Fedora/RPM Fusion working!
ExternalProject_Add(libkeyfinder
URL "https://github.com/mixxxdj/libkeyfinder/archive/v2.2.4.zip"
URL_HASH SHA256=cb3fea8c7213257281b6c7006b2430809f466ad8a1d485663324378d6fc0782c