summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-27 14:05:59 +0100
committerJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-28 15:04:10 +0100
commit7760fc03e3ee998de2f4ce82b55e10b776c10699 (patch)
treeb16cd4afecdf58bfdbe729c76bd941c30c00b278 /CMakeLists.txt
parent5c39548f0cc3dad633f99658e4c8443423db0352 (diff)
CMake: Disable warnings suggesting MSVC-only extensions (strncpy_s, ...)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bc9bf8ac6..afc168c76b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -947,7 +947,7 @@ if(MSVC)
target_compile_options(mixxx-lib PUBLIC /W4)
else()
target_compile_options(mixxx-lib PUBLIC /W3)
- target_compile_definitions(mixxx-lib PUBLIC _SILENCE_CXX17_ITERATOR_BASE_CLASS_DEPRECATION_WARNING)
+ target_compile_definitions(mixxx-lib PUBLIC _SILENCE_CXX17_ITERATOR_BASE_CLASS_DEPRECATION_WARNING _CRT_SECURE_NO_WARNINGS)
endif()
else()
target_compile_options(mixxx-lib PUBLIC -Wall -Wextra -Wfloat-conversion)