summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2020-03-18 15:17:09 +0100
committerUwe Klotz <uklotz@mixxx.org>2020-03-18 18:36:39 +0100
commit3823c9ab4085f1f1f726c8783a239f45e8a9365c (patch)
tree2e1f45b8ed460d90905c5b71dae065576d93cf1f /CMakeLists.txt
parentd442159c4e5b37342b221c98b7573c0ebed53d15 (diff)
Install license files and docs in separate directories
- /usr/share/docs/mixxx - /usr/share/licenses/mixxx This layout reflects the file structure used by RedHat and Arch.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bbcd0a8628..30aeecda9d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -885,10 +885,18 @@ install(
${CMAKE_INSTALL_DATADIR}/mixxx
)
-# Documentation
+# Licenses
install(
FILES
${CMAKE_CURRENT_SOURCE_DIR}/LICENSE
+ ${CMAKE_CURRENT_SOURCE_DIR}/COPYING
+ DESTINATION
+ ${CMAKE_INSTALL_DATADIR}/licenses/mixxx
+)
+
+# Documentation
+install(
+ FILES
${CMAKE_CURRENT_SOURCE_DIR}/README
${CMAKE_CURRENT_SOURCE_DIR}/Mixxx-Manual.pdf
DESTINATION