summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBe <be@mixxx.org>2020-11-03 07:43:47 -0600
committerBe <be@mixxx.org>2020-11-03 13:23:35 -0600
commit36e5689380ebedc329e59fbbaba0c53c111abd0d (patch)
treef278f4b721d4d00ca8f7a46a63e8d477e9b27d68 /CMakeLists.txt
parent555b9fd5a26fcfc67cb678389dd12d9276717ce4 (diff)
CMakeLists: add /c option to MSVC builds for clcache
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7927a10ccf..af84931720 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1000,6 +1000,8 @@ if(WIN32)
target_link_libraries(mixxx-lib PUBLIC shell32)
if(MSVC)
+ # needed for clcache
+ target_compile_options(mixxx-lib PUBLIC /c)
if(NOT STATIC_DEPS OR CMAKE_BUILD_TYPE STREQUAL "Debug")
target_link_options(mixxx-lib PUBLIC /nodefaultlib:LIBCMT.lib /nodefaultlib:LIBCMTd.lib)
endif()