summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2020-03-18 22:54:32 +0100
committerUwe Klotz <uklotz@mixxx.org>2020-03-19 01:06:31 +0100
commit2c648c2ef0a3fd4d7b8f42ac61ce96281bc0209b (patch)
tree46f4e40691013fc77b7eb660fa8c5f920052b166 /CMakeLists.txt
parentfc305f82e049cfa51a7cf1892502adfd7ca17224 (diff)
Disable installation of GoogleTest libraries
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30aeecda9d..f49f91450c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -957,6 +957,9 @@ include(CPack)
# when building with Visual Studio
set(gtest_force_shared_crt ON CACHE BOOL "Pass Mixxx compiler/linker options to GoogleTest" FORCE)
+# Prevent installation of GoogleTest libraries
+set(INSTALL_GTEST OFF CACHE BOOL "Disable installation of GoogleTest" FORCE)
+
# Add googletest directly to our build. This adds the following targets:
# gtest, gtest_main, gmock and gmock_main
add_subdirectory(