summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-01-31 02:47:10 +0200
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-02-04 02:55:45 +0200
commitbb80de91aee1fd2953ba142693076188e64223a5 (patch)
treeae84e88551b919c41c4306ed2dab8c7fe650d7fa /debian/rules
parentcd1ed5ef405deeaf55b60aa2d871145308271478 (diff)
Makefile: add debian/ and deb-dist target to build *.deb package
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..d3277b92
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@ --with quilt
+
+#override_dh_auto_install:
+# dh_auto_install -- prefix=/usr
+
+#override_dh_install:
+# dh_install --list-missing -X.pyc -X.pyo