summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2019-09-28 23:11:48 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2019-09-28 23:11:48 +0300
commitc7bcb9e553c9eaea307bdbec0ca9f6d1d31051c9 (patch)
treeaf881e8a4549a3059a263b95ede5dd0b19883603 /Cargo.toml
parentb7edec02746e2a22da5242594fa63b46cac3ab9e (diff)
Reexport debug-tracing feature from main Cargo.toml
Main crate's feature didn't enable the same feature in the workspace subcrates.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 3 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 168a6028..612060c6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,9 +15,6 @@ signal-hook = "0.1.10"
nix = "*"
melib = { path = "melib", version = "*" }
ui = { path = "ui", version = "*" }
-#enable for debug tracing logs
-#melib = { path = "melib", version = "*", features=["debug-tracing",] }
-#ui = { path = "ui", version = "*", features=["debug-tracing",] }
[profile.release]
lto = true
@@ -28,7 +25,7 @@ members = ["melib", "ui", "debug_printer", "testing", "text_processing"]
[features]
default = []
+
# Print tracing logs as meli runs in stderr
-#
-# enable for debug tracing logs
-# debug-tracing = []
+# enable for debug tracing logs: build with --features=debug-tracing
+debug-tracing = ["melib/debug-tracing", "ui/debug-tracing"]