summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-10-17 20:50:29 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-10-17 20:50:29 +0300
commit89940dd60636ec3e5ba84d734724a2867ea34c1a (patch)
tree84a75f86435c0502edea6c7b16763c679812d403 /Cargo.toml
parentb69bc219c30b4690e83ade5346cc0f4bade7e511 (diff)
cli-docs: compress included text
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d7dd6328..1e73817a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -57,11 +57,13 @@ svg_crate = { version = "0.8.0", optional = true, package = "svg" }
futures = "0.3.5"
async-task = "3.0.0"
num_cpus = "1.12.0"
+flate2 = { version = "1.0.16", optional = true }
[build-dependencies]
syn = { version = "1.0.31", features = [] }
quote = "^1.0"
proc-macro2 = "1.0.18"
+flate2 = { version = "1.0.16", optional = true }
[profile.release]
lto = "fat"
@@ -80,7 +82,7 @@ sqlite3 = ["melib/sqlite3"]
smtp = ["melib/smtp"]
regexp = ["pcre2"]
dbus-notifications = ["notify-rust",]
-cli-docs = []
+cli-docs = ["flate2"]
svgscreenshot = ["svg_crate"]
gpgme = ["melib/gpgme"]