summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-05-30 15:35:51 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-05-30 15:37:12 +0300
commit6ceed3cae9a13764262913b4d9a1b8302b213551 (patch)
treeb284ef54be807ee7a250ebfec4c265327dd6fca5 /Cargo.toml
parent815ff98acc73201bfbd079414104169162a0fa0d (diff)
sqlite3: move module to melib
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 43792771..c8e0a6c5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -44,7 +44,6 @@ bincode = "1.2.0"
uuid = { version = "0.8.1", features = ["serde", "v4"] }
unicode-segmentation = "1.2.1" # >:c
libc = {version = "0.2.59", features = ["extra_traits",]}
-rusqlite = {version = "0.20.0", optional =true }
rmp = "^0.8"
rmpv = { version = "^0.4.2", features=["with-serde",] }
rmp-serde = "^0.14.0"
@@ -64,7 +63,7 @@ members = ["melib", "testing", ]
default = ["sqlite3", "notmuch"]
notmuch = ["melib/notmuch_backend", ]
jmap = ["melib/jmap_backend",]
-sqlite3 = ["rusqlite"]
+sqlite3 = ["melib/sqlite3"]
cli-docs = []
# Print tracing logs as meli runs in stderr