summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-10-28 23:28:41 +0200
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-10-28 23:28:41 +0200
commit57e6cf39809ca9436b8a592918e226c3fa3b1ed3 (patch)
treee1dec2d99c97e6c65badad8d112fd691b79bf490 /Cargo.toml
parent9a9c876f4a88bd941ae7b2761f98fa25e424e6ce (diff)
Limit dbus dependency to target_os = "linux"
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 78cb35a4..4f4995b7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -40,7 +40,6 @@ toml = { version = "0.5.6", features = ["preserve_order", ] }
indexmap = { version = "^1.5", features = ["serde-1", ] }
linkify = "0.4.0"
notify = "4.0.1" # >:c
-notify-rust = { version = "^4", optional = true }
termion = "1.5.1"
bincode = "1.2.0"
uuid = { version = "0.8.1", features = ["serde", "v4"] }
@@ -55,6 +54,9 @@ futures = "0.3.5"
async-task = "3.0.0"
num_cpus = "1.12.0"
flate2 = { version = "1.0.16", optional = true }
+
+[target.'cfg(target_os="linux")'.dependencies]
+notify-rust = { version = "^4", optional = true }
[build-dependencies]
syn = { version = "1.0.31", features = [] }