summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2019-11-30 17:30:34 +0200
committerManos Pitsidianakis <el13635@mail.ntua.gr>2019-11-30 17:31:49 +0200
commit49dccb94a5fb5016144e68b5ec36269625add34b (patch)
treebc8cf7d5ef38d4770926e5655bbdd33d4d12586c /Cargo.toml
parent6653357d5410dfbd868acd59dbf81cba863b1abb (diff)
bin: add notmuch feature
Add notmuch feature that includes melib/notmuch_backend and a new feature for the ui crate. We need the latter in order to know from within ui if we have been linked with libnotmuch
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 612060c6..6e481e1b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -25,6 +25,7 @@ members = ["melib", "ui", "debug_printer", "testing", "text_processing"]
[features]
default = []
+notmuch = ["melib/notmuch_backend", "ui/notmuch"]
# Print tracing logs as meli runs in stderr
# enable for debug tracing logs: build with --features=debug-tracing