summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-09-10 20:31:12 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-09-10 21:19:38 +0300
commit1ac3a7a903e50ec72a092c3de4fe81d633e1d43a (patch)
tree852e7ff6afaabfdb71d8b4f1660bdc5d4222348c /Cargo.toml
parentfaa12a2d41a84997b57c65390647cc54ae4e2f7d (diff)
Make dbus dependency optional
Put dbus dependency behing `dbus-notifications` feature.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f3187e20..89ead05b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -41,7 +41,7 @@ indexmap = { version = "^1.5", features = ["serde-1", ] }
linkify = "0.4.0"
xdg-utils = "0.3.0"
notify = "4.0.1" # >:c
-notify-rust = "^3" # >:c
+notify-rust = { version = "^4", optional = true }
termion = "1.5.1"
bincode = "1.2.0"
uuid = { version = "0.8.1", features = ["serde", "v4"] }
@@ -73,12 +73,13 @@ debug = false
members = ["melib", "tools", ]
[features]
-default = ["sqlite3", "notmuch", "regexp", "smtp"]
+default = ["sqlite3", "notmuch", "regexp", "smtp", "dbus-notifications"]
notmuch = ["melib/notmuch_backend", ]
jmap = ["melib/jmap_backend",]
sqlite3 = ["melib/sqlite3"]
smtp = ["melib/smtp"]
regexp = ["pcre2"]
+dbus-notifications = ["notify-rust",]
cli-docs = []
svgscreenshot = ["svg_crate"]