summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-06-12 01:37:57 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-06-12 01:37:57 +0300
commit0618e62ab6b22e36cd1393626818d01e445a9c1a (patch)
tree88dd12a92a350916f6bf7156905c65730cf314e1 /Cargo.toml
parentbc0189ffa1e09ccf895af4bda254cf4ba3da1975 (diff)
Add optional feature to save SVG screenshot
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index eca68f9c..f26581ef 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -50,6 +50,7 @@ smallvec = { version = "1.1.0", features = ["serde", ] }
bitflags = "1.0"
pcre2 = { version = "0.2.3", optional = true }
structopt = { version = "0.3.14", default-features = false }
+svg_crate = { version = "0.8.0", optional = true, package = "svg" }
[profile.release]
@@ -67,6 +68,7 @@ jmap = ["melib/jmap_backend",]
sqlite3 = ["melib/sqlite3"]
regexp = ["pcre2"]
cli-docs = []
+svgscreenshot = ["svg_crate"]
# Print tracing logs as meli runs in stderr
# enable for debug tracing logs: build with --features=debug-tracing