summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Wiesner <sebastian@swsnr.de>2018-08-26 11:14:31 +0200
committerSebastian Wiesner <sebastian@swsnr.de>2018-08-26 11:14:31 +0200
commit7375eafbab2c0934a266826b54d3a4889bd5efda (patch)
treeed2be340d15954cc7ea5deb6ccea0bff76f569b9 /Cargo.toml
parentc8ec0d6c2d63c61232552a9f1592463f3074abd3 (diff)
Enable all terminal emulators by default
We can't enable features in build.rs, see https://github.com/rust-lang/cargo/issues/5499, and cargo doesn't support target-specific default features, see https://github.com/rust-lang/cargo/issues/1197. Essentially we build as we used to do before we added features for terminal emulators. Downsides are more dependencies than needed—you don’t need iterm2 on Linux after all—and Windows doesn't build with default features at all. This reverts commit 544943adf3befc5051d47847dc59c6071af7675b.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 28e4892..f6fa31d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,16 +10,17 @@ version = "0.8.1-pre"
categories = ["command-line-utilities", "text-processing"]
license = "Apache-2.0"
authors = ["Sebastian Wiesner <sebastian@swsnr.de>"]
-build = "build.rs"
[badges]
travis-ci = { repository = "lunaryorn/mdcat" }
maintenance = { status = "actively-developed" }
[features]
-default = []
+default = ["iterm2", "terminology"]
+# Enable special support for iTerm2.
iterm2 = ["mime", "base64"]
+# Enable special support for Terminology.
terminology = ["immeta"]
[dependencies]