summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorEric Hodel <drbrain@segment7.net>2022-09-22 14:56:04 -0700
committerEric Hodel <drbrain@segment7.net>2022-09-22 14:56:04 -0700
commit5a3432d1b28ef9a065dd37aa77b82a3593358793 (patch)
tree989ae41e47c9fa058635f33b1ef73c16966cb9f1 /Cargo.toml
parentff4055846ac93e13dc0ce4a52c391d925f443676 (diff)
Use mdbook v0.4.21
On rust 1.64.0 mdbook v0.4.18 fails to compile: Compiling mdbook v0.4.18 error[E0597]: `local_ctx` does not live long enough --> /Users/erichodel/.cargo/registry/src/github.com-1ecc6299db9ec823/mdbook-0.4.18/src/renderer/html_handlebars/helpers/navigation.rs:154:25 | 154 | t.render(r, &local_ctx, &mut local_rc, out) | ^^^^^^^^^^ borrowed value does not live long enough 155 | })?; | - | | | `local_ctx` dropped here while still borrowed | borrow might be used here, when `local_rc` is dropped and runs the destructor for type `handlebars::RenderContext<'_, '_>` | = note: values in a scope are dropped in the opposite order they are defined For more information about this error, try `rustc --explain E0597`. error: could not compile `mdbook` due to previous error warning: build failed, waiting for other jobs to finish...
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b21ffc8..119e44a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,7 +9,7 @@ repository = "https://github.com/badboy/mdbook-mermaid"
edition = "2018"
[dependencies]
-mdbook = { version = "0.4.10", default-features = false }
+mdbook = { version = "0.4.21", default-features = false }
pulldown-cmark = { version = "0.9.0", default-features = false }
env_logger = "0.9.0"
log = "0.4.11"