summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJan-Erik Rediger <janerik@fnordig.de>2021-04-06 14:00:09 +0200
committerJan-Erik Rediger <janerik@fnordig.de>2021-04-06 14:00:09 +0200
commit0b98d594276550bcd2ee35cfa977c2e37266709a (patch)
tree39b1b7af0dcc53f844d40c009227980d6cda2a43 /Cargo.toml
parent6bb54e54aaaea399c530c941b4afb43866c8576c (diff)
Add tests for the `install` subcommand
These test that it modifies the book.toml and compares it against the expected output.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ca8ee32..286d083 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,4 +19,6 @@ serde_json = "1.0.57"
toml_edit = "0.2.0"
[dev-dependencies]
-pretty_assertions = "0.6.1"
+assert_cmd = "1.0.3"
+pretty_assertions = "0.7.1"
+tempfile = "3.2.0"