summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 12 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ad2dfc9..3c2ed42 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,6 +10,7 @@ readme = "./README.md"
repository = "https://github.com/lsd-rs/lsd"
version = "1.0.0"
edition = "2021"
+rust-version = "1.70"
[[bin]]
name = "lsd"
@@ -28,27 +29,27 @@ human-sort = "0.2.2"
term_grid = "0.1.*"
terminal_size = "0.1.*"
thiserror = "1.0"
-sys-locale = "0.2.4"
+sys-locale = "0.3"
once_cell = "1.17.1"
chrono = { version = "0.4.*", features = ["unstable-locales"] }
-chrono-humanize = "0.1.*"
+chrono-humanize = "0.2"
unicode-width = "0.1.*"
lscolors = "0.15.0"
-wild = "2.0.*"
+wild = "2.0"
globset = "0.4.*"
-xdg = "2.1.*"
+xdg = "2.1"
yaml-rust = "0.4.*"
serde = { version = "1.0", features = ["derive"] }
serde_yaml = "0.8"
-url = "2.1.*"
-vsort = "0.1.0"
+url = "2.1"
+vsort = "0.2"
[target."cfg(not(all(windows, target_arch = \"x86\", target_env = \"gnu\")))".dependencies]
# if ssl feature is enabled compilation will fail on arm-unknown-linux-gnueabihf and i686-pc-windows-gnu
-git2 = { version = "0.16", optional = true, default-features = false }
+git2 = { version = "0.18", optional = true, default-features = false }
[target.'cfg(unix)'.dependencies]
-users = "0.11.*"
+users = { version = "0.11.3", package = "uzers" }
xattr = "1"
[target.'cfg(windows)'.dependencies]
@@ -59,11 +60,11 @@ features = ["derive", "wrap_help"]
version = "4.1"
[dev-dependencies]
-assert_cmd = "1"
+assert_cmd = "2"
assert_fs = "1"
-predicates = "1.0.1"
+predicates = "3"
tempfile = "3"
-serial_test = "0.5"
+serial_test = "2.0"
[features]
default = ["git2"]