summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c3d77d0..f33a635 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,8 +17,8 @@ name = "lsd"
path = "src/main.rs"
[build-dependencies]
-clap = { version = "4.1", features = ["derive"] }
-clap_complete = "4.1"
+clap = { version = "4.3.*", features = ["derive"] }
+clap_complete = "4.3"
version_check = "0.9.*"
[dependencies]
@@ -31,7 +31,7 @@ terminal_size = "0.3"
thiserror = "1.0"
sys-locale = "0.3"
once_cell = "1.17.1"
-chrono = { version = "0.4.*", features = ["unstable-locales"] }
+chrono = { version = "0.4.19", features = ["unstable-locales"] }
chrono-humanize = "0.2"
unicode-width = "0.1.*"
lscolors = "0.16.0"
@@ -42,6 +42,7 @@ serde = { version = "1.0", features = ["derive"] }
serde_yaml = "0.9"
url = "2.1"
vsort = "0.2"
+xdg = "2.5"
[target."cfg(not(all(windows, target_arch = \"x86\", target_env = \"gnu\")))".dependencies]
# if ssl feature is enabled compilation will fail on arm-unknown-linux-gnueabihf and i686-pc-windows-gnu
@@ -56,7 +57,7 @@ windows = { version = "0.43.0", features = ["Win32_Foundation", "Win32_Security_
[dependencies.clap]
features = ["derive", "wrap_help"]
-version = "4.1"
+version = "4.3.*"
[dev-dependencies]
assert_cmd = "2"