summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/meson.build b/test/meson.build
index 2632aa3..fc5661f 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -1,7 +1,8 @@
+# Note: Boost Test is used in header-only mode.
boost_test_dep = dependency('boost', modules : ['system', 'filesystem'])
# Dependencies required by all unit test executables.
-test_deps = [boost_test_dep, sqlite3_dep, sqlite_modern_cpp_dep]
+test_deps = [boost_test_dep, thread_dep]
engine_library_test_names = [
'crate_test',
@@ -17,7 +18,7 @@ foreach test_name : engine_library_test_names
'el_' + test_name,
'enginelibrary/' + test_name + '.cpp',
cpp_args : ['-DTESTDATA_DIR=' + testdata_dir],
- include_directories : [inc, internal_inc],
+ include_directories : [inc],
dependencies : test_deps,
link_with : djinterop_lib)
test(test_name, exe)