summaryrefslogtreecommitdiffstats
path: root/include/djinterop/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'include/djinterop/meson.build')
-rw-r--r--include/djinterop/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/djinterop/meson.build b/include/djinterop/meson.build
index c43a0b2..1ec6646 100644
--- a/include/djinterop/meson.build
+++ b/include/djinterop/meson.build
@@ -4,6 +4,9 @@
# of configure_file() does not, at the time of writing (meson 0.55.0), support
# writing the output file to a different directory.
conf_data = configuration_data()
+if default_library_type == 'static'
+ conf_data.set10('DJINTEROP_STATIC', true)
+endif
if cpp_compiler.has_header('optional')
conf_data.set10('DJINTEROP_STD_OPTIONAL', true)
endif