summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorhaslersn <sebastian.hasler@gmx.net>2019-06-27 16:37:33 +0200
committerhaslersn <sebastian.hasler@gmx.net>2019-07-08 00:37:28 +0200
commitd246cfdb8e7bc75761c7972b4e1203bdbc6ca44b (patch)
tree96ec21997eab43829d223f8fffc91b833dd490d8 /src/meson.build
parentf7939f56d650ed999172050fe58093c0b24e15b4 (diff)
treewide: Rework API
The API methods now operate directly on the database. Therefore, the classes don't have a `save()` method anymore. Also, the distinction between tracks and their performance data has been hidden from the API user. That is, the performance data attributes are now accessible directly through the `track` API. This is WORK IN PROGRESS. See the TODOs.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 6191bad..3b9cae1 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,6 +1,7 @@
sources = [
'enginelibrary/crate.cpp',
'enginelibrary/database.cpp',
+ 'enginelibrary/database_impl.cpp',
'enginelibrary/encode_decode_utils.cpp',
'enginelibrary/performance_data_format.cpp',
'enginelibrary/performance_data.cpp',
@@ -8,6 +9,7 @@ sources = [
'enginelibrary/schema_1_7_1.cpp',
'enginelibrary/schema.cpp',
'enginelibrary/track.cpp',
+ 'enginelibrary/util.cpp',
'sqlite3.c'
]