summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorAdam Szmigin <smidge@xsco.net>2020-05-27 22:25:35 +0100
committerAdam Szmigin <smidge@xsco.net>2020-05-27 22:25:35 +0100
commita310f347e2508acb91c7b2b988631030d0fa9df6 (patch)
tree2f44411d68232efa64351de19c2a0f51b629c6a7 /src/meson.build
parent19bfefb8fd4e16ace02106dd51f68ce10f3f459e (diff)
SQLite3 is now an external dependency
Removed in-tree SQLite3 amalgamation in favour of system dependency. Updated meson and CMake build scripts accordingly.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 8c5edae..e730244 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -19,9 +19,11 @@ sources = [
'djinterop/impl/track_impl.cpp',
'djinterop/impl/transaction_guard_impl.cpp',
'djinterop/impl/util.cpp',
- 'sqlite3.c'
]
+# Dependencies required by the main library.
+core_deps = [thread_dep, dl_dep, sqlite3_dep, zlib_dep, boost_dep]
+
# Used by unit tests to reference internal classes.
internal_inc = include_directories('.')