summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Szmigin <smidge@xsco.net>2020-02-18 17:39:29 +0000
committerAdam Szmigin <smidge@xsco.net>2020-02-18 17:39:29 +0000
commit7ea64154ccd94a1e2152315e9c221062521bc145 (patch)
tree98b7fe46fd0d02fe73978717c45acf46ab195e96 /meson.build
parent7d839bc6d3e6f732014a274d856af471eb06fa67 (diff)
Use std::optional where available
Either <optional> or <experimental/optional> is now required for compilation and in the public API. In order to seamlessly use either one, the relevant symbols are aliased within the namespace `djinterop::stdx`. It is expected that this is removed in favour of just using std::optional in future once older compiler support can be removed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 30ef055..3cb59cf 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
'cpp', 'c',
version: '0.8.7',
license: 'LGPL-3.0',
- default_options: ['cpp_std=c++14', 'c_std=c11'])
+ default_options: ['cpp_std=c++17', 'c_std=c11'])
add_global_arguments('-D_MODERN_SQLITE_BOOST_OPTIONAL_SUPPORT', language: 'cpp')