summaryrefslogtreecommitdiffstats
path: root/server/Cargo.toml
diff options
context:
space:
mode:
authorFelix <me@nutomic.com>2020-01-14 16:26:19 +0100
committerFelix <me@nutomic.com>2020-01-14 16:30:54 +0100
commiteaf548b5db326addee318bcc2c7c742e4b79b6fa (patch)
treefebdc483976b5e3d38db4c68cfadd57ce89b3f61 /server/Cargo.toml
parent35489a706bdd48bdb840a4ac13986214c456d6c9 (diff)
parentb300db475cbca846aea89800ecaa8661c59fd70b (diff)
Merge branch 'master' into federation
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml23
1 files changed, 12 insertions, 11 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index ef2343f4..3d198d19 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -7,21 +7,22 @@ edition = "2018"
[dependencies]
diesel = { version = "1.4.2", features = ["postgres","chrono", "r2d2"] }
diesel_migrations = "1.4.0"
-dotenv = "0.14.1"
-bcrypt = "0.5.0"
-activitypub = "0.1.5"
+dotenv = "0.15.0"
+bcrypt = "0.6.1"
+activitypub = "0.2.0"
chrono = { version = "0.4.7", features = ["serde"] }
failure = "0.1.5"
serde_json = { version = "1.0.40", features = ["preserve_order"]}
serde = { version = "1.0.94", features = ["derive"] }
-actix = "0.8.3"
-actix-web = "1.0"
-actix-files = "0.1.3"
-actix-web-actors = "1.0"
-env_logger = "0.6.2"
+actix = "0.9.0"
+actix-web = "2.0.0"
+actix-files = "0.2.1"
+actix-web-actors = "2.0.0"
+actix-rt = "1.0.0"
+env_logger = "0.7.1"
rand = "0.7.0"
-strum = "0.15.0"
-strum_macros = "0.15.0"
+strum = "0.17.1"
+strum_macros = "0.17.1"
jsonwebtoken = "6.0.1"
regex = "1.1.9"
lazy_static = "1.3.0"
@@ -30,6 +31,6 @@ lettre_email = "0.9.2"
sha2 = "0.8.0"
rss = "1.8.0"
htmlescape = "0.3.1"
-config = "0.9.3"
+config = "0.10.1"
hjson = "0.8.2"
reqwest = "0.9.24" \ No newline at end of file