summaryrefslogtreecommitdiffstats
path: root/server/Cargo.toml
diff options
context:
space:
mode:
authorDessalines <tyhou13@gmx.com>2020-03-18 22:30:16 -0400
committerDessalines <tyhou13@gmx.com>2020-03-18 22:30:16 -0400
commitdc14719b08a431b7cdc19de4cc6fd93b3a9da5f6 (patch)
treeae9595b03c2f4525c38a667fa285ef7ed82b1201 /server/Cargo.toml
parent231f7822609b3c8be8c78b7bad917ab88bafcb13 (diff)
Updating rust, rust deps, yarn deps. Fixes #605
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index 10c0dfc8..97fc12cb 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -8,12 +8,12 @@ edition = "2018"
diesel = { version = "1.4.2", features = ["postgres","chrono", "r2d2", "64-column-tables"] }
diesel_migrations = "1.4.0"
dotenv = "0.15.0"
-bcrypt = "0.6.1"
+bcrypt = "0.6.2"
activitypub = "0.2.0"
chrono = { version = "0.4.7", features = ["serde"] }
failure = "0.1.5"
-serde_json = { version = "1.0.45", features = ["preserve_order"]}
-serde = { version = "1.0.94", features = ["derive"] }
+serde_json = { version = "1.0.48", features = ["preserve_order"]}
+serde = { version = "1.0.105", features = ["derive"] }
actix = "0.9.0"
actix-web = "2.0.0"
actix-files = "0.2.1"
@@ -22,10 +22,10 @@ actix-rt = "1.0.0"
log = "0.4.0"
env_logger = "0.7.1"
rand = "0.7.3"
-strum = "0.17.1"
-strum_macros = "0.17.1"
+strum = "0.18.0"
+strum_macros = "0.18.0"
jsonwebtoken = "7.0.1"
-regex = "1.3.4"
+regex = "1.3.5"
lazy_static = "1.3.0"
lettre = "0.9.2"
lettre_email = "0.9.2"