summaryrefslogtreecommitdiffstats
path: root/server/Cargo.toml
diff options
context:
space:
mode:
authorDessalines <tyhou13@gmx.com>2020-01-03 23:41:44 -0500
committerDessalines <tyhou13@gmx.com>2020-01-03 23:41:44 -0500
commita68fd4f2aa42bffad0b32bac42e87926de88b39f (patch)
treedd2bff1f7906943df3f60967c02d1ab80f6e4e99 /server/Cargo.toml
parent13cd2e82de3242e5394e51de979d26133e2e2caa (diff)
Updating cargo deps.
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index 382e9be0..fc04fd2d 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -7,9 +7,9 @@ edition = "2018"
[dependencies]
diesel = { version = "1.4.2", features = ["postgres","chrono", "r2d2"] }
diesel_migrations = "1.4.0"
-dotenv = "0.14.1"
-bcrypt = "0.5.0"
-activitypub = "0.1.5"
+dotenv = "0.15.0"
+bcrypt = "0.6.1"
+activitypub = "0.2.0"
chrono = { version = "0.4.7", features = ["serde"] }
failure = "0.1.5"
serde_json = { version = "1.0.40", features = ["preserve_order"]}
@@ -18,10 +18,10 @@ actix = "0.8.3"
actix-web = "1.0"
actix-files = "0.1.3"
actix-web-actors = "1.0"
-env_logger = "0.6.2"
+env_logger = "0.7.1"
rand = "0.7.0"
-strum = "0.15.0"
-strum_macros = "0.15.0"
+strum = "0.17.1"
+strum_macros = "0.17.1"
jsonwebtoken = "6.0.1"
regex = "1.1.9"
lazy_static = "1.3.0"
@@ -30,5 +30,5 @@ lettre_email = "0.9.2"
sha2 = "0.8.0"
rss = "1.8.0"
htmlescape = "0.3.1"
-config = "0.9.3"
+config = "0.10.1"
hjson = "0.8.2"