summaryrefslogtreecommitdiffstats
path: root/server/Cargo.toml
diff options
context:
space:
mode:
authorDessalines <tyhou13@gmx.com>2020-03-24 15:18:08 -0400
committerDessalines <tyhou13@gmx.com>2020-03-24 15:18:08 -0400
commit945fd8331beb41af40cf73be8f0e61cba5c74be0 (patch)
treef2bac83c5d3a10ddb70c2dba97ff6d6b6b248db7 /server/Cargo.toml
parent1d824ee29385169724d812fc19e4ab2b8ce4a1df (diff)
parent4354f868fdf7234398db1fcdff02c5583bbf5198 (diff)
Merge branch 'nutomic-federation' into federation
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index 82823057..c694c88c 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -5,11 +5,11 @@ authors = ["Dessalines <happydooby@gmail.com>"]
edition = "2018"
[dependencies]
-diesel = { version = "1.4.2", features = ["postgres","chrono", "r2d2"] }
+diesel = { version = "1.4.2", features = ["postgres","chrono", "r2d2", "64-column-tables"] }
diesel_migrations = "1.4.0"
dotenv = "0.15.0"
bcrypt = "0.6.1"
-activitypub = "0.2.0"
+activitystreams = "0.5.0-alpha.10"
chrono = { version = "0.4.7", features = ["serde"] }
failure = "0.1.5"
serde_json = { version = "1.0.45", features = ["preserve_order"]}
@@ -19,6 +19,7 @@ actix-web = "2.0.0"
actix-files = "0.2.1"
actix-web-actors = "2.0.0"
actix-rt = "1.0.0"
+log = "0.4.0"
env_logger = "0.7.1"
rand = "0.7.3"
strum = "0.17.1"
@@ -33,4 +34,6 @@ rss = "1.9.0"
htmlescape = "0.3.1"
config = "0.10.1"
hjson = "0.8.2"
-reqwest = "0.9.24" \ No newline at end of file
+url = "2.1.1"
+percent-encoding = "2.1.0"
+chttp = "0.5.5"