summaryrefslogtreecommitdiffstats
path: root/server/Cargo.toml
diff options
context:
space:
mode:
authorDessalines <dessalines@users.noreply.github.com>2020-05-15 12:36:11 -0400
committerGitHub <noreply@github.com>2020-05-15 12:36:11 -0400
commit940dc73f280742e553395d6a56eaca015a234b3a (patch)
treee81748decb1dc10d1ace2ad6318a94d063ccf23c /server/Cargo.toml
parent3a4973ad68562f9ccb4a9f4442333e0478bc7b04 (diff)
Federated mentions. Fixes #681 (#717)
* Federated mentions. Fixes #681 * Changing some todos, adding comments.
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index ab76d06f..cf680b66 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -8,17 +8,17 @@ edition = "2018"
diesel = { version = "1.4.4", features = ["postgres","chrono","r2d2","64-column-tables","serde_json"] }
diesel_migrations = "1.4.0"
dotenv = "0.15.0"
-activitystreams = "0.6.0"
-bcrypt = "0.6.2"
+activitystreams = "0.6.1"
+bcrypt = "0.8.0"
chrono = { version = "0.4.7", features = ["serde"] }
-failure = "0.1.5"
+failure = "0.1.8"
serde_json = { version = "1.0.48", features = ["preserve_order"]}
serde = { version = "1.0.105", features = ["derive"] }
actix = "0.9.0"
actix-web = "2.0.0"
actix-files = "0.2.1"
actix-web-actors = "2.0.0"
-actix-rt = "1.0.0"
+actix-rt = "1.1.1"
log = "0.4.0"
env_logger = "0.7.1"
rand = "0.7.3"
@@ -36,13 +36,13 @@ config = "0.10.1"
hjson = "0.8.2"
url = { version = "2.1.1", features = ["serde"] }
percent-encoding = "2.1.0"
-isahc = "0.9"
+isahc = "0.9.2"
comrak = "0.7"
openssl = "0.10"
http = "0.2.1"
-http-signature-normalization = "0.4.1"
-base64 = "0.12.0"
-tokio = "0.2.18"
-futures = "0.3.4"
+http-signature-normalization = "0.5.1"
+base64 = "0.12.1"
+tokio = "0.2.21"
+futures = "0.3.5"
itertools = "0.9.0"
uuid = { version = "0.8", features = ["serde", "v4"] }