summaryrefslogtreecommitdiffstats
path: root/server/Cargo.toml
diff options
context:
space:
mode:
authorFelix <me@nutomic.com>2020-02-29 12:42:44 +0100
committerFelix <me@nutomic.com>2020-02-29 12:42:44 +0100
commit7cdf167e4b28b08e9df90e874be31891ca904f26 (patch)
tree1dd024469c9b5f18abbe4a41a27afdde058ba06a /server/Cargo.toml
parentb854d8f3a0d484fd08bedc75e237fcc2c5eb4a67 (diff)
pull in activitypub library
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index 82823057..1b6ea305 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -13,6 +13,7 @@ activitypub = "0.2.0"
chrono = { version = "0.4.7", features = ["serde"] }
failure = "0.1.5"
serde_json = { version = "1.0.45", features = ["preserve_order"]}
+serde_derive = "1.0"
serde = { version = "1.0.94", features = ["derive"] }
actix = "0.9.0"
actix-web = "2.0.0"
@@ -33,4 +34,11 @@ rss = "1.9.0"
htmlescape = "0.3.1"
config = "0.10.1"
hjson = "0.8.2"
-reqwest = "0.9.24" \ No newline at end of file
+reqwest = "0.9.24"
+activitystreams-derive = "0.2"
+activitystreams-traits = "0.2"
+activitystreams-types = "0.3"
+
+
+[dev-dependencies]
+anyhow = "1.0"