summaryrefslogtreecommitdiffstats
path: root/jq.spec
diff options
context:
space:
mode:
authorLee Thompson <stagr.lee@gmail.com>2013-02-03 14:49:03 -0600
committerLee Thompson <stagr.lee@gmail.com>2013-02-03 14:49:03 -0600
commit43fd939f1628ce88274b28aaa284946f00e8aadb (patch)
tree20710c7173eb2d580527c64be81248ff3b9c28f2 /jq.spec
parentd8a072ca011c525885b7f79cc888a64392644e09 (diff)
rework build to not distribute tests unless --enable-devel is specificied to autoconf
Diffstat (limited to 'jq.spec')
-rw-r--r--jq.spec31
1 files changed, 20 insertions, 11 deletions
diff --git a/jq.spec b/jq.spec
index 35db1ae1..3697ed02 100644
--- a/jq.spec
+++ b/jq.spec
@@ -2,9 +2,9 @@
# Your OS of choice will likely ignore this RPM spec file.
Summary: Command-line JSON processor
Name: jq
-Version: %{version}
-Release: %{release}
-Source0: jq-%{version}.tar.gz
+Version: %{myver}
+Release: %{myrel}%{?dist}
+Source0: jq-%{myver}.tar.gz
URL: https://github.com/stedolan/jq
License: BSD
AutoReqProv: no
@@ -18,16 +18,22 @@ Group: Applications/System
%global debug_package %{nil}
%global __os_install_post %{nil}
+# Crank up the compression
+%define _binary_payload w7.lzdio
+
%description
jq is a command-line JSON processor
%prep
-
%setup
%build
echo "Building in: \"$(pwd)\""
+%if "%{devbuild}" == "yes"
+./configure --prefix=%{_prefix} --enable-devel
+%else
./configure --prefix=%{_prefix}
+%endif
make
%install
@@ -40,13 +46,16 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/jq
-%{_bindir}/jq_test
-%{_datadir}/doc/jq/AUTHORS
-%{_datadir}/doc/jq/COPYING
-%{_datadir}/doc/jq/INSTALL
-%{_datadir}/doc/jq/NEWS
-%{_datadir}/doc/jq/README
-%{_datadir}/doc/jq/README.md
+%if "%{devbuild}" == "yes"
+%{_libexecdir}/%{name}/jq_test
+%{_libexecdir}/%{name}/testdata
+%endif
+%{_datadir}/doc/%{name}/AUTHORS
+%{_datadir}/doc/%{name}/COPYING
+%{_datadir}/doc/%{name}/INSTALL
+%{_datadir}/doc/%{name}/NEWS
+%{_datadir}/doc/%{name}/README
+%{_datadir}/doc/%{name}/README.md
%changelog