summaryrefslogtreecommitdiffstats
path: root/jq.spec
diff options
context:
space:
mode:
authorLee Thompson <thompson@dtosolutions.com>2012-12-03 16:19:45 -0600
committerLee Thompson <thompson@dtosolutions.com>2012-12-03 16:19:45 -0600
commit26bbed29f72742ddfb39b0684e78bc4d2780de51 (patch)
tree0dd26ff46587995a5f4ad54628ffb76a1a2b08b2 /jq.spec
parentddeec45b2ea79fc23277e9ff8d0e70c929ba61a8 (diff)
start work on getting RPM to work with tarball
Diffstat (limited to 'jq.spec')
-rw-r--r--jq.spec42
1 files changed, 42 insertions, 0 deletions
diff --git a/jq.spec b/jq.spec
new file mode 100644
index 00000000..71b3e792
--- /dev/null
+++ b/jq.spec
@@ -0,0 +1,42 @@
+Summary: Command-line JSON processor
+Name: jq
+Version: %{version}
+Release: %{release}
+Source0: jq-%{version}.tgz
+URL: https://github.com/stedolan/jq
+
+License: Copyright (C) 2012 Stephen Dolan
+Group: Applications/System
+# Requires:
+
+# Disables debug packages and stripping of binaries:
+%global _enable_debug_package 0
+%global debug_package %{nil}
+%global __os_install_post %{nil}
+
+%description
+jq is a command-line JSON processor
+
+%prep
+
+%setup
+
+%build
+
+%install
+echo "Building in: \"%{buildroot}\""
+rm -rf %{buildroot}
+install -d -m 755 %{buildroot}/usr/bin
+mv %{_builddir}/jq-%{version}/bin/jq %{buildroot}/usr/bin
+
+%clean
+
+%files
+%defattr(-,root,root)
+/usr/bin/jq
+
+%changelog
+
+%pre
+
+%post