summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Dolan <mu@netsoc.tcd.ie>2013-05-09 11:31:17 +0100
committerStephen Dolan <mu@netsoc.tcd.ie>2013-05-09 11:31:17 +0100
commitf6089a627a932bad7cfd5c8030bf32fcc9888996 (patch)
treeef1eece9787f1f4df579b5dbcffee9f74e133dfb /configure.ac
parent898dc8978b546c3c67a5678cc6101643b160d710 (diff)
Autotools hackery so that "make dist" builds lexer and parser.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 5bbc0b55..503ceaa0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,18 +20,18 @@ dnl
dnl these program checks should probably be deleted
dnl
+AC_PROG_LEX
+if test "x$LEX" != xflex; then
+ LEX="$SHELL $missing_dir/missing flex"
+fi
+
+
dnl Check for flex
AC_CHECK_PROGS(flex_cmd, flex)
if test x$flex_cmd = "x" ; then
AC_MSG_NOTICE([flex is required to patch jq.])
fi
-dnl Check for bison
-AC_CHECK_PROGS(bison_cmd, bison)
-if test x$bison_cmd = "x" ; then
- AC_MSG_NOTICE([bison is required to patch jq.])
-fi
-
dnl Check for valgrind
AC_CHECK_PROGS(valgrind_cmd, valgrind)
if test x$valgrind_cmd = "x" ; then
@@ -40,7 +40,7 @@ fi
dnl AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS(config.h)
-AM_INIT_AUTOMAKE([-Wall dist-bzip2 dist-zip])
+AM_INIT_AUTOMAKE([-Wall])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT