summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@gmail.com>2015-06-27 10:16:13 -0700
committerDavid Tolnay <dtolnay@gmail.com>2015-06-27 11:25:01 -0700
commite6371712fff2e899afd312473584bb1223d7cf86 (patch)
tree2f042631ef7b158802fcf41c26c5bd5cfc9357e6 /configure.ac
parentd7e35101c537a8ec7c86e8e19313e8a20dd72ce3 (diff)
flag to enable gcov and coveralls
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af619fbe..16544295 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,10 @@ dnl fix leaks.
AC_ARG_ENABLE([valgrind],
AC_HELP_STRING([--disable-valgrind], [do not run tests under Valgrind]))
+dnl Code coverage
+AC_ARG_ENABLE([gcov],
+ AC_HELP_STRING([--enable-gcov], [enable gcov code coverage tool]))
+
dnl Don't attempt to build docs if there's no Ruby lying around
AC_ARG_ENABLE([docs],
AC_HELP_STRING([--disable-docs], [don't build docs]))
@@ -126,6 +130,7 @@ EOF
])
AM_CONDITIONAL([ENABLE_VALGRIND], [test "x$enable_valgrind" != xno])
+AM_CONDITIONAL([ENABLE_GCOV], [test "x$enable_gcov" = xyes])
AM_CONDITIONAL([ENABLE_DOCS], [test "x$enable_docs" != xno])
AM_CONDITIONAL([ENABLE_ERROR_INJECTION], [test "x$enable_error_injection" = xyes])
AM_CONDITIONAL([ENABLE_ALL_STATIC], [test "x$enable_all_static" = xyes])