summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLee Thompson <thompson@dtosolutions.com>2012-11-28 01:08:23 -0600
committerLee Thompson <thompson@dtosolutions.com>2012-11-28 01:08:23 -0600
commitddeec45b2ea79fc23277e9ff8d0e70c929ba61a8 (patch)
tree1c7ceac2c9341011dd406923f5e7d0331a830b1b /configure.ac
parent006357f954c72bf4212bbc16e869efbfe9d06eda (diff)
revert back to make invoking flex, fix a few bugs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 09997385..52037ca8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,9 +8,13 @@ AM_INIT_AUTOMAKE([parallel-tests])
AC_PROG_CC
AC_PROG_CC_STDC
AC_PROG_CPP_WERROR
+AC_PROG_YACC
AM_PROG_CC_C_O
+dnl couldn't use AM_PROG_LEX as it doesn't support header files like the
+dnl AC_PROG_YACC macros...
+
dnl CFLAGS is concidered a packagers variable, not a developer variable
dnl in Auto-tools. For developer ease of use, CFLAGS are set how the
dnl developers like them by default but the packager can disable if so
@@ -28,6 +32,10 @@ if test "$enable_devcflags" = "yes"; then
AM_CONDITIONAL(DEVCFLAGS_ENABLED, true)
fi
+dnl
+dnl these program checks should probably be deleted
+dnl
+
dnl Check for sed
AC_CHECK_PROGS(regex_cmd, sed)
if test x$regex_cmd = "x" ; then
@@ -46,8 +54,6 @@ if test x$bison_cmd = "x" ; then
AC_MSG_NOTICE([bison is required to patch jq.])
fi
- AC_CONFIG_HEADERS(config.h)
-
dnl Check for python
AC_CHECK_PROGS(python_cmd, python)
if test x$python_cmd = "x" ; then
@@ -61,6 +67,7 @@ if test x$valgrind_cmd = "x" ; then
fi
dnl AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([-Wall dist-bzip2 dist-zip])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT