summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Dolan <mu@netsoc.tcd.ie>2013-05-08 02:30:08 +0100
committerStephen Dolan <mu@netsoc.tcd.ie>2013-05-08 02:42:23 +0100
commitd121420757001950604473f5b0f7a592caa1433e (patch)
treefe1d5c043fdc81d8b431d2558e83120860bf11c2 /configure.ac
parent1ebb3825400074dc62e92d161f76a57ef4fd40d4 (diff)
Clean up autotools config.
Remove some of @stagrlee's hard work since jq's testsuite is less silly than when he wrote the autotools config.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 3 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 5f939493..fe81d972 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,33 +16,10 @@ AM_PROG_CC_C_O
dnl couldn't use AM_PROG_LEX as it doesn't support header files like the
dnl AC_PROG_YACC macros...
-dnl CFLAGS is concidered a packagers variable, not a developer variable
-dnl in Auto-tools. For developer ease of use, CFLAGS are set how the
-dnl developers like them by default but the packager can disable if so
-dnl desired. This is useful if something other than gcc is needed or
-dnl for distros that need to heavily tweek the compiler (gentoo, ARM cpu
-dnl linux's, etc)
-AC_ARG_ENABLE(
- [devel],
- [AC_HELP_STRING(
- [--enable-devel],
- [Build the tests and enable the same CFLAGS used by jq developers @<:@default=no@:>@])],
- [],
- [enable_devel=no]
-)
-AC_MSG_RESULT($enable_devel)
-AM_CONDITIONAL([DEVELOPMENT_ENABLED], [test x$enable_devel = xyes])
-
dnl
dnl these program checks should probably be deleted
dnl
-dnl Check for sed
-AC_CHECK_PROGS(regex_cmd, sed)
-if test x$regex_cmd = "x" ; then
- AC_MSG_NOTICE([sed is required to patch jq.])
-fi
-
dnl Check for flex
AC_CHECK_PROGS(flex_cmd, flex)
if test x$flex_cmd = "x" ; then
@@ -55,12 +32,6 @@ if test x$bison_cmd = "x" ; then
AC_MSG_NOTICE([bison is required to patch jq.])
fi
-dnl Check for python
-AC_CHECK_PROGS(python_cmd, python)
-if test x$python_cmd = "x" ; then
- AC_MSG_NOTICE([python is required to patch jq.])
-fi
-
dnl Check for valgrind
AC_CHECK_PROGS(valgrind_cmd, valgrind)
if test x$valgrind_cmd = "x" ; then
@@ -72,3 +43,6 @@ AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([-Wall dist-bzip2 dist-zip])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
+
+
+dnl FIXME should disable colour output on windows somehow