summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Langford <wlangfor@gmail.com>2019-02-20 20:50:08 -0500
committerNico Williams <nico@cryptonector.com>2019-02-26 11:10:38 -0600
commitc1f11855e31e3975ef74c7d19304bee4e1b64e71 (patch)
treed445f62627063331c80f3b6e2b70c9465afdd8a9 /configure.ac
parent76e72a301db9883dc13073ac64187d48d4eade41 (diff)
Remove ruby dependency from website build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 97f4eab4..e8c6a71e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,7 +74,7 @@ dnl Code coverage
AC_ARG_ENABLE([gcov],
AC_HELP_STRING([--enable-gcov], [enable gcov code coverage tool]))
-dnl Don't attempt to build docs if there's no Ruby lying around
+dnl Don't attempt to build docs if python deps aren't installed
AC_ARG_ENABLE([docs],
AC_HELP_STRING([--disable-docs], [don't build docs]))
@@ -87,25 +87,25 @@ AC_ARG_ENABLE([all-static],
AC_HELP_STRING([--enable-all-static], [link jq with static libraries only]))
AS_IF([test "x$enable_docs" != "xno"],[
- AC_CHECK_PROGS(bundle_cmd, bundle)
+ AC_CHECK_PROGS(pipenv_cmd, pipenv)
- AC_CACHE_CHECK([for Ruby dependencies], [jq_cv_ruby_deps],
- [jq_cv_ruby_deps=yes;
- AS_IF([test "x$bundle_cmd" = "x" || \
- ! bmsg="`cd ${srcdir}/docs; "$bundle_cmd" check 2>/dev/null`"],[
- AC_MSG_WARN([$bmsg])
+ AC_CACHE_CHECK([for Python dependencies], [jq_cv_python_deps],
+ [jq_cv_python_deps=yes;
+ AS_IF([test "x$pipenv_cmd" = "x" || \
+ ! bmsg="`cd ${srcdir}/docs; LC_ALL=$LANG "$pipenv_cmd" check`"],[
+ AC_MSG_ERROR([$bmsg])
cat <<EOF
*****************************************************************
-* Ruby dependencies for building jq documentation not found. *
+* Python dependencies for building jq documentation not found. *
* You can still build, install and hack on jq, but the manpage *
* will not be rebuilt and some of the tests will not run. *
* See docs/README.md for how to install the docs dependencies. *
*****************************************************************
EOF
- jq_cv_ruby_deps=no
+ jq_cv_python_deps=no
])])
- if test "x$jq_cv_ruby_deps" != "xyes"; then
+ if test "x$jq_cv_python_deps" != "xyes"; then
enable_docs=no
fi
])