summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Langford <wlangfor@gmail.com>2019-04-03 21:55:39 -0400
committerWilliam Langford <wlangfor@gmail.com>2019-10-22 14:11:04 -0400
commit74c44bc9a35ff7da4481b6e8c5036c0ffa93aa17 (patch)
tree46223409def975188a4b1b35d2b3bd78306e47ee /configure.ac
parent4860ed439605ded0964fad0ae7b43d0ae8600174 (diff)
Add configure guards around literal jv_numbers
Allow building jq in a mode that doesn't use decnumber for benchmarking purposes. decnumber support is enabled by default, and this option is meant to be removed once we're happy with the performance.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d6bf1cb..7d2355b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,6 +110,14 @@ EOF
fi
])
+dnl Disable decNumber support
+AC_ARG_ENABLE([decnum],
+ AC_HELP_STRING([--disable-decnum], [disable decnum support]))
+
+AS_IF([test "x$enable_decnum" != "xno"],[
+ AC_DEFINE([USE_DECNUM],1)
+])
+
AM_CONDITIONAL([ENABLE_VALGRIND], [test "x$enable_valgrind" != xno])
AM_CONDITIONAL([ENABLE_ASAN], [test "x$enable_asan" = xyes])
AM_CONDITIONAL([ENABLE_UBSAN], [test "x$enable_ubsan" = xyes])