summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDoug Luce <doug@github.con.com>2015-06-18 11:07:16 -0700
committerNicolas Williams <nico@cryptonector.com>2015-06-18 19:19:15 -0500
commit3cbefde37656f2d3655e020e5922d33f44834187 (patch)
treed0ee04f93eb73a3eadd4ce689e770e81265f9c05 /configure.ac
parent0b424579291c1da2d5adb439b66a090dc023c1ea (diff)
Add alloca() discovery to configure.ac
The build failed on FreeBSD as there is no alloca.h. This patch is lifted from the autoconf documentation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf236194..ccbe8dcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,6 +123,8 @@ AM_CONDITIONAL([ENABLE_DOCS], [test "x$enable_docs" != xno])
AM_CONDITIONAL([ENABLE_ERROR_INJECTION], [test "x$enable_error_injection" = xyes])
AM_CONDITIONAL([ENABLE_ALL_STATIC], [test "x$enable_all_static" = xyes])
+AC_FUNC_ALLOCA
+
AC_FIND_FUNC([isatty], [c], [#include <unistd.h>], [0])
AC_FIND_FUNC([_isatty], [c], [#include <io.h>], [0])
AC_FIND_FUNC([strptime], [c], [#include <time.h>], [0, 0, 0])